rasbianにnpmでmongodbドライバを入れるまで

前回の続き。

以下のインストールで成功したという情報があったので実行


npm install -g node-gyp

特に効果なし・・・

debianのnodejsのバージョンが古いからapt-getでなく手動で入れる必要があるという情報に行きあたる。rasbian用のnodejsはここからダウンロードできるらしい。

root@raspberrypi:~# node -v #現在のバージョン
v0.10.29
root@raspberrypi:~# sudo dpkg -i node_latest_armhf.deb
root@raspberrypi:~# node -v #最新のバージョン
v4.2.1

これで無事npmでmongodbドライバをインストールできました。
ということで原因はnodeが古すぎたようです。